Technical Requirements

Welcome to the Bula website.  To use the site, you will need to have a few things in place, many of which you likely already have.

Browsers: Bula supports the latest version, and one previous version of each modern browser on desktop and laptop computers.  These include:
 

  • Internet Explorer 11 on Windows 7, 8 & 10

  • Microsoft Edge on Windows 10

  • Firefox (with auto-update enabled) on Windows 7, 8 & 10 and Mac OS X

  • Chrome (with auto-update enabled) on Windows 7, 8 & 10 and Mac OS X

  • Safari (with auto-update enabled) on Mac OS X
     

If you are not using one of the above browsers, you can download a new browser from various sources including BrowseHappy.com or Browser-Update.org.  Though the site may function correctly on older browsers, on phones, or tablets, you may experience unusual issues with older browsers.
 

Network: Bula uses Content Delivery Networks (CDNs) to load additional content onto the site.  If you are having difficulty loading content on the Bula website, ensure that your network does not block the following content:

If you need assistance, feel free to contact us.